Results 1 to 4 of 4
  1. #1
    New JK Freak
    Join Date
    09-09-2018
    Location
    SoCal
    Posts
    7

    Oil pressure problem

    I need some help! I'm getting the PO6DD code on my 3.6L which is the oil pressure code for the 2 stage oil pump. I can clear the code and go almost a day before it comes back and limits me to 3500 RPM or less. I have searched the internet and this site and need to see who has had this issue and the fix? I have purchased a MOPAR oil filter as suggested and the engine oil level is perfect. I'm reading it can be the filter, pressure sensor, the oil pump or the O ring on the oil pickup tube in the pan. I was thinking about doing the sensor first as it's the cheapest part although the labor is over $200 due to the location of the sensor under the intake! Poor design for a part that may need replaced at some point. If the sensor doesn't work then what? Any and all suggestions would be appreciated as I have a trip planned for Sedona in early January. Thank you
    Last edited by jscribn1; 12-01-2018 at 01:56 AM.

  2. #2
    Freaking JK Guru TheDirtman's Avatar
    Join Date
    11-30-2011
    Location
    Southwest Reno, NV
    Posts
    4,553
    Have you had someone with a good scanner do a diagnostic? The big boy scanners can give you better info. The O ring would be the cheapest route to go as you just drop the oil pan. The intake is not that big a deal to remove either but if you don't have the tools or skills then you are at the mercy of a shop and things take time.

  3. #3
    New JK Freak
    Join Date
    09-09-2018
    Location
    SoCal
    Posts
    7
    I haven't had it diagnosed with a legit scanner yet. I have an appt. with my mechanic on Tuesday. I found a good write up on Wayalife and it details all the steps to do the oil filter housing / cooler. I got a good look in there last night and it's not leaking oil in the valley area where everyone sees the leaks. I have a decent set of tools and it doesn't seem too hard I've just never delt with the intake before, gaskets, fuel rails etc. I was also reading about replacing the filter housing / cooler assembly to put in a 2014 or newer part # to use the new filter design. Any suggestions or advice on that issue? Thanks for the reply, doesn't seem like too much traffic on this site but you always seems to reply and have great advice, thank you!!

  4. #4
    New JK Freak
    Join Date
    09-09-2018
    Location
    SoCal
    Posts
    7
    Got it to my mechanic today. He pulled the intake off and the filter housing was not leaking at all. The valley was dry as a bone. He replaced the pressure sensor with a new Mopar one. He told me it looks like a completely different design so we're hoping it's an upgraded one that will last more thank 58k. He scanned it to read oil pressures, oil temps, and coolant temps and all checked out. He road tested it and no CEL. I'll pick her up tomorrow and see how she does.
    Justin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •